Blocks

Compatibility

ExpressionEngine

Blocks has been tested on the following ExpressionEngine versions:

  • 2.8.1
  • 2.9.2
  • 2.10.1

Field types

Blocks is only as good as the field types that it can use to create blocks. Below is a list of known compatible field types.

ExpressionEngine's native fieldtypes

Blocks can use the following ExpressionEngine native fieldtypes.

  • Checkboxes
  • Date
  • File
  • Multi Select
  • Radio
  • Relationships
  • Rich Text
  • Select
  • Text
  • Textarea

Third-party field types opted in by Blocks

Blocks is a field type for content, so it is essential that Blocks has good content field types available. Because of this, I have specifically tested and opted in support for the following third-party field types.

Third-party field types that support Blocks

Field types can opt to work with Blocks. The following is an incomplete list of known field types that work with Blocks.

If you have a field type and would like to support Blocks, check out Field Type Development for Blocks. If your field type already supports Blocks and you would like it listed here, please fill out the Contact Form to send me a link to your add-on.